How to portforward for Minecraft server (2024)

Post Reply

  • Print view
StonePlex

just joined

Topic Author

Posts: 1
Joined: Mon Mar 23, 2020 12:32 pm

How to portforward for Minecraft server

  • Quote
  • #1

Mon Mar 23, 2020 12:46 pm

Hi! I have been trying to portforward for my minecraft server but, I can't get it to work. I am a noob when it comes to these things so I need help. I have tried multiple solutions with the GUI or the terminal solutions, but they don't seem to work. Here are some of the commands I tried.

Code: Select all

ip firewall filter add chain=forward dst-address=192.168.88.142 protocol=tcp dst-port=25565 action=accept

Code: Select all

/ip firewall nat add chain=dstnat protocol=tcp dst-port=25565 in-interface=wlan1 action=dst-nat to-address=192.168.88.142 to-ports=25565 

Code: Select all

/ip firewall natadd chain=dstnat action=dst-nat dst-port=25565 protocol=tcp in-interface=wlan1 \to-address=192.168.88.142 to-ports=25565

I can't get it to work. It works localy, but thats it.
I have tried to disable the Firewall itself, but my router doesn't allow it.

Code: Select all

/ip firewall filter disable [/ip firewall filter find]

I get an error: failiure: cannot change builtin

Need help. I am open to any solution.

Top

anav

Forum Guru
How to portforward for Minecraft server (3)

Posts: 20457
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Contact anav

Re: How to portforward for Minecraft server

  • Quote
  • #2

Mon Mar 23, 2020 2:52 pm

Yes,
1. Only one firewall rule is needed for port forwarding (whether you have one server or 20 - assuming NAT of course)
2. You need one dstnat rule per server.

1. If you still have the default firewall rule in place............. it will work just fine.
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN

2. For the destination nat rule..... I am confused by wlan1 but will assume you have your INTERNET coming on on WLAN1? In any case Try
add chain=dstnat action=dst-nat protocol=tcp dst-port=25565 in-interface=WAN to-address=192.168.88.142

dont need to-ports if no change from dst-port.

Top

hahnhell

Member Candidate
How to portforward for Minecraft server (5)

Posts: 108
Joined: Sat Mar 07, 2020 11:49 pm
Location: NCR, Canada

Re: How to portforward for Minecraft server

  • Quote
  • #3

Sat Nov 21, 2020 4:03 am

I know this is a bit of a hijack, but i'm trying to do the exact same thing here... My port forwarding attempts don't seem to be working either.

I've tried in the past, have had a complete redo of my network layout, and I still can't seem to get it working.

@anav, i'm willing to take the time to learn this one and debug it completely.. The kids and their minecraft is not as important as it was to get their school work up and going!

I've done this exact same thing, trying to get to my server (192.168.15.10) same port. Nada. :(

I'm using the Mikrotik cloud service. When I go to the address, I end up seeing my router homepage (login page). But I can't seem to get 25565 to work.

Top

anav

Forum Guru
How to portforward for Minecraft server (7)

Posts: 20457
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Contact anav

Re: How to portforward for Minecraft server

  • Quote
  • #4

Sat Nov 21, 2020 5:03 am

No worries, post your config for me to look at.

Top

NevadaNV

just joined

Posts: 1
Joined: Sun Nov 22, 2020 6:47 pm

Re: How to portforward for Minecraft server

  • Quote
  • #5

Sun Nov 22, 2020 6:55 pm

No worries, post your config for me to look at.

Hi! I am experiencing exact the same problem, I've done everything and still canyouseeme.org can't see my 25565 port.
I've done

Code: Select all

/ip firewall nat add chain=dstnat protocol=tcp dst-port=25565 in-interface=sfp1 action=dst-nat to-address=192.168.88.100 to-ports=25565

and

Code: Select all

/ip firewall filter add chain=forward dst-address=192.168.88.100 protocol=tcp dst-port=25575 action=accept

I also placed them on top of other rules, opened the 25565 port on my server and called my ISP support to see whether they blocked any ports, they didnt. Still nothing. Any ideas on what else I could do?

Top

hahnhell

Member Candidate
How to portforward for Minecraft server (10)

Posts: 108
Joined: Sat Mar 07, 2020 11:49 pm
Location: NCR, Canada

Re: How to portforward for Minecraft server

  • Quote
  • #6

Wed Nov 25, 2020 10:32 pm

Sorry, I forgot to subscribe to this thread and was just waiting to see it hit my inbox... fail!

Here's my config..

You do not have the required permissions to view the files attached to this post.

Top

anav

Forum Guru
How to portforward for Minecraft server (12)

Posts: 20457
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Contact anav

Re: How to portforward for Minecraft server

  • Quote
  • #7

Thu Nov 26, 2020 12:22 am

Hmmm,
Only thing in firewall rules to clarify is that your IOT devices are not included in list internet and thus cannot access the internet.
All my IOT devices need to talk to the internet cloud of some sort???

The firewall rule for port forwarding is the default one so it looks okay but needs to be refined!
The second last rules in the forward chain could be cleaned up as its slightly redundant due to the more encompassing last rule> The idea here is to state what traffic you are allowing......
From
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN

add action=drop chain=forward comment="drop all else"

TO
add action=accept chain=forward comment="allow port forwarding" \
connection-nat-state=dstnat connection-state=new in-interface-list=WAN
add action=drop chain=forward comment="drop all else"

As far as port forwarding.......
add action=dst-nat chain=dstnat comment="Minecraft Server" dst-port=25565 \
in-interface=PPPoE_WAN protocol=tcp to-addresses=192.168.15.10

Hmmm try
in-interface-list=WAN to see if that help?

Top

anav

Forum Guru
How to portforward for Minecraft server (14)

Posts: 20457
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Contact anav

Re: How to portforward for Minecraft server

  • Quote
  • #8

Thu Nov 26, 2020 12:28 am

Just to confirm,

You are trying to reach the servers via the WANIP??
WHY............. just use the lanip of the server??

If the server is in the same LANIP of the user and trying to reach it via WANIP of the router then that is called hairpin NAT>
The easiest solution is to move the server to another vlan by itself and that will solve that for example or you need to make more rules in IP NAT.

Alternatively you can get a friend to see if they can get at the server from their WANIP, as hairpin nat or often called loopback is a local phenomena.
What functionality do you want to have??

Top

hahnhell

Member Candidate
How to portforward for Minecraft server (16)

Posts: 108
Joined: Sat Mar 07, 2020 11:49 pm
Location: NCR, Canada

Re: How to portforward for Minecraft server

  • Quote
  • #9

Thu Nov 26, 2020 1:37 am

I'm trying to port forward this so that I can connect to it from outside my network.

I am using the lanIP for the devices inside the network, that works just fine. I want to be able to invite others to it is the issue.

Top

hahnhell

Member Candidate
How to portforward for Minecraft server (18)

Posts: 108
Joined: Sat Mar 07, 2020 11:49 pm
Location: NCR, Canada

Re: How to portforward for Minecraft server

  • Quote
  • #10

Thu Nov 26, 2020 1:46 am

And, now that I changed that second to last rule, it seems to be working.

Thank you very much @anav! Have a good one.

Top

atoh

just joined

Posts: 1
Joined: Mon Jan 04, 2021 3:11 am

Re: How to portforward for Minecraft server

  • Quote
  • #11

Mon Jan 04, 2021 5:08 pm

Hi!
Im super new to this and i dont fully quite understand how to setup a minecraft server, but i would like to. Im trying to setup my router so i can play with my friends

Im not sure what i am doing wrong but this is what i have done

/ip firewall nat add chain=dstnat protocol=tcp dst.port=25565 in.interface=ether1 action=dst-nat to-address=192.168.88.35 to-ports=25565

/ip firewall filter add chain=forward dst-address=192.168.88.35 protocol=tcp dst.port=25565 in.interface=ether1 action=allow

i was following what you said in this thread @anav and im not sure what im doing wrong

Top

Post Reply

  • Print view

Who is online

Users browsing this forum: Bing [Bot] and 17 guests

How to portforward for Minecraft server (2024)

FAQs

How do I setup port forwarding on my MC server? ›

How to Port Forward Minecraft?
  1. Step 1 – Set the Port on Minecraft Configuration. ...
  2. Step 2 – Allow the Port on Your Firewall. ...
  3. Step 3 – Forward the Port on the Router. ...
  4. Step 4 – Restart the Minecraft Server and Connect.
Jul 18, 2024

How do I port forward to a server? ›

Set Up Port Forwarding
  1. Log in to the router as admin. ...
  2. Locate the port forwarding options. ...
  3. Type the port number or port range that you want to forward. ...
  4. Choose a protocol, either TCP or UDP ports. ...
  5. Type the static IP address you chose. ...
  6. Enable the port forwarding rule with an Enable or On option.
May 3, 2022

How do I setup port forwarding for a game server? ›

How to port forward your router for gaming
  1. Find the private IP of your gaming device, your router's IP address and the port the game uses.
  2. Enter the router IP address in your browser.
  3. Login to view browser settings (try “admin” as both username and password).
  4. Find the port forwarding section.
Nov 10, 2023

How to enable port forwarding? ›

How to open ports on a router
  1. Access your router's web interface. Navigate to your router's configuration page by typing the router's IP address into your browser.
  2. Log in to your router. ...
  3. Find the port forwarding section. ...
  4. Add a new port forwarding rule. ...
  5. Save the changes.
Jun 19, 2023

Do you forward TCP or UDP ports for Minecraft? ›

If you're running a server for Minecraft: Java Edition, you need to forward both TCP and UDP ports 25565. However, if you're hosting a Minecraft: Bedrock Edition server, the requirements differ. In this case, you should forward both UDP and TCP ports 19132 and 19133.

What port is 25565? ›

To play Minecraft online and create a server without any interruptions, you'll have to allow access to certain ports on your firewall. The default Minecraft ports are: TCP Port: 25565. UDP Port: 19132.

How to check if a Minecraft server is port forwarded? ›

After completing port forwarding, go to www.portchecktool.com to check if port 25565 is open. If it is, you will see a “Success!” message. Further port forwarding assistance can be found in our General Port Forwarding Guide.

Is port forwarding safe for gaming? ›

Forwarding a port to a PlayStation or Xbox is safe. Port forwarding a security camera or computer is also safe but has low reliability. Your computer is safe from external threats while port forwarding if you are using Windows Vista, Windows 7, 8, or 10. Why do you ask?

Do you need to port forward to join a server? ›

Without port forwarding, players won't be able to join your server, and you won't be able to connect to other servers.

How do I configure a port on my server? ›

Click Start > All Programs > Administrative Tools > Windows Firewall with Advanced Security.
  1. Select Inbound Rules.
  2. Select Action > New Rule.
  3. Proceed with the New Inbound Rule Wizard and enter the following information: Rule Type = Port. Protocol and Ports = TCP. Specific port = 8031. Action = Allow the connection.

Is TCP or UDP better for gaming? ›

UDP is better if you're gaming online, because its speedy data transfer allows for mostly lag-free gaming. TCP is better if you're transferring files, like family photos, because it ensures the data arrives exactly as it was sent.

Should I use port forwarding or port triggering for gaming? ›

Yes, port triggering is good for gaming as it provides network stability while playing games and makes the connection secure. Is DMZ better than port forwarding? Yes, DMZ is better than port forwarding. However, it is not necessary to do it.

How to open ports on router for gaming? ›

Port forwarding games: Manual steps
  1. Sign in to your router.
  2. Find the port forwarding section, which can be found somewhere in the security section.
  3. Now, you can set up gaming port forwarding, but need to know your IP address and port numbers first.
  4. With all this in place, your ports are open to access.

Do you need a static IP for port forwarding? ›

Any port forwarding configuration you make on your router needs to be fixed to a certain IP address, so it's important that it doesn't change. That's why we walk you through the steps of configuring a Static IP address.

How to check if port forwarding is working? ›

We recommend using a reliable port forward tool like www.portchecktool.com. The port forward checker tool is a valuable resource for network troubleshooting. It helps you check whether your ISP (Internet Service Provider) is blocking specific ports, such as the commonly restricted HTTP port 80 and SMTP port 25.

Why is my port forwarding not working for Minecraft? ›

The issue “Minecraft Server Port Forwarding not working” might happen in one of the following cases: The status of the Port Forwarding function is closed during checking. Windows Firewall or the security programs installed on the computer cause interface and mess with the Port Forwarding function.

What is the port number for the Minecraft server? ›

Minecraft server port

By default Minecraft servers run on port 25565 , this port is assumed if an address is entered without a port specified.

How to join Minecraft World through port? ›

When the local IP and port are found, type them into the "Server Address" field (under either Direct Connect or in the Add Server dialogue), formatted like IP:port (e.g. 192.168.1.1:5000) to join the LAN game. Note: Using one Minecraft account on two or more computers will not work to join the same world.

How to port forward Minecraft on TP Link? ›

How to Port Forward a TP-Link Router
  1. Step 1: Login to the TP-Link router via the default gateway address.
  2. Step 2: Click on “Forwarding” and then “Virtual Servers.”
  3. Step 3: Click “Add New.”
  4. Step 4: Enter the Service Port, Internal Port and IP Address. ...
  5. Step 5: Click “Save.”

Top Articles
Unspeakable Phone Number 2023
Principal identifies high school student killed in Massachusetts crash
SZA: Weinen und töten und alles dazwischen
Custom Screensaver On The Non-touch Kindle 4
Durr Burger Inflatable
It may surround a charged particle Crossword Clue
Free Atm For Emerald Card Near Me
New Slayer Boss - The Araxyte
Undergraduate Programs | Webster Vienna
DL1678 (DAL1678) Delta Historial y rastreo de vuelos - FlightAware
Top Hat Trailer Wiring Diagram
Items/Tm/Hm cheats for Pokemon FireRed on GBA
Aucklanders brace for gales, hail, cold temperatures, possible blackouts; snow falls in Chch
Mzinchaleft
Palm Coast Permits Online
Inside the life of 17-year-old Charli D'Amelio, the most popular TikTok star in the world who now has her own TV show and clothing line
Walgreens Tanque Verde And Catalina Hwy
Lista trofeów | Jedi Upadły Zakon / Fallen Order - Star Wars Jedi Fallen Order - poradnik do gry | GRYOnline.pl
Ge-Tracker Bond
Sussur Bloom locations and uses in Baldur's Gate 3
Like Some Annoyed Drivers Wsj Crossword
8005607994
Understanding Gestalt Principles: Definition and Examples
Troy Gamefarm Prices
Asteroid City Showtimes Near Violet Crown Charlottesville
Workshops - Canadian Dam Association (CDA-ACB)
Cable Cove Whale Watching
Craigslist Brandon Vt
Wolfwalkers 123Movies
Lesson 1.1 Practice B Geometry Answers
Shoe Station Store Locator
Tripcheck Oregon Map
Rays Salary Cap
Mastering Serpentine Belt Replacement: A Step-by-Step Guide | The Motor Guy
Was heißt AMK? » Bedeutung und Herkunft des Ausdrucks
Indiana Jones 5 Showtimes Near Jamaica Multiplex Cinemas
Ultra Clear Epoxy Instructions
A Man Called Otto Showtimes Near Amc Muncie 12
Hisense Ht5021Kp Manual
Chuze Fitness La Verne Reviews
Cherry Spa Madison
Encompass.myisolved
511Pa
Crystal Glassware Ebay
Theater X Orange Heights Florida
Movie Hax
Sky Dental Cartersville
Race Deepwoken
Blippi Park Carlsbad
Blog Pch
Noelleleyva Leaks
91 East Freeway Accident Today 2022
Latest Posts
Article information

Author: Otha Schamberger

Last Updated:

Views: 6229

Rating: 4.4 / 5 (55 voted)

Reviews: 86% of readers found this page helpful

Author information

Name: Otha Schamberger

Birthday: 1999-08-15

Address: Suite 490 606 Hammes Ferry, Carterhaven, IL 62290

Phone: +8557035444877

Job: Forward IT Agent

Hobby: Fishing, Flying, Jewelry making, Digital arts, Sand art, Parkour, tabletop games

Introduction: My name is Otha Schamberger, I am a vast, good, healthy, cheerful, energetic, gorgeous, magnificent person who loves writing and wants to share my knowledge and understanding with you.